Nachdem nun Gimp 2.8 erschienen ist, welches nicht unerhebliche Änderungen mit sich bringt, wollte auch ich in den Genuss dieser neuen Version gelangen. Dabei bin ich auf folgende Anleitung gestoßen:

http://www.muktware.com/3580/how-install-gimp-28-opensuse

Diese funktioniert auch bis auf eine Kleinigkeit: Beim Start erscheint folgender Fehler.
The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.8.0, but the
libgimp version is 2.6.11

Das Problem war, dass nach der 1-Klick Installation die Quelle für libbabl-0_1-0; libgimp-2_0-0 und libgimpui-2_0-0 nicht auf die neue MargueriteSu Quelle geändert wurden.

Folgender Befehl im Terminal hat hier Abhilfe geschaffen:

sudo zypper dup

Nun kann man all die tollen Neuerungen selbst ausprobieren / nutzen. Viel Spaß.